const regex = /(?<!^(?:(?:\d+|[A-Z])\.?)?)\t/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^(?:(?:\\d+|[A-Z])\\.?)?)\\t', 'gm')
const str = ` text
1. text
1 text
A. text
text text
That is, it shouldn't match tabs that are
at the beginning of the text,
after a listed item mark [A-Z] or [0-9]. Here is my expression:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}