$re = '/\(([^)(]*)\)(?=(?:[^)(]*\([^)(]*\))*[^)(]*\))/m';
$str = 'Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
a(b(c)(c)b(c))(b((d)c(d)c(d)(d)))';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;