re = /\(([^)(]*)\)(?=(?:[^)(]*\([^)(]*\))*[^)(]*\))/m
str = 'Record ID
What is the best food? (choice=Nachos)
What is the best food? (choice=Tacos (big bent nachos))
What is the best food? (choice=Chips with stuff)
Complete?
So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))
a(b(c)(c)b(c))(b((d)c(d)c(d)(d)))'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result