using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\w)[\w \tÑñáéíóú(\.:\-,)?]{20,500}$";
string input = @"Workers were given gifts (working)
Part-time workers were given gifts.
...................................";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}