re = /^(?=.*\w)[\w \tÑñáéíóú(\.:\-,)?]{20,500}$/m
str = 'Workers were given gifts (working)
Part-time workers were given gifts.
...................................'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end