$re = '/.*;(?<value>.*);/m';
$str = 'SITES;Bypass;Whitelist;Finance;User Business Accept';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);