re = /.*;(?<value>.*);/m
str = 'SITES;Bypass;Whitelist;Finance;User Business Accept'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end