#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*(INFO) (\S+) (joomlafailure).*(Passwort|falsch|wrong|password)"
Local $sString = "" & @CRLF & _
"2022-10-13T12:29:30+00:00 INFO 194.34.132.57 joomlafailure Benutzername und Passwort falsch oder das Benutzerkonto existiert noch nicht!" & @CRLF & _
"2022-10-13T12:29:33+00:00 INFO 194.34.132.57 joomlafailure Benutzername und Passwort falsch oder das Benutzerkonto existiert noch nicht!" & @CRLF & _
"" & @CRLF & _
"2022-10-13T12:36:09+00:00 INFO 194.34.132.57 joomlafailure Username and password do not match or you do not have an account yet." & @CRLF & _
"2022-10-13T12:36:12+00:00 INFO 194.34.132.57 joomlafailure Username and password do not match or you do not have an account yet." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")