$re = '/.*(INFO) (\S+) (joomlafailure).*(Passwort|falsch|wrong|password)/m';
$str = '
2022-10-13T12:29:30+00:00 INFO 194.34.132.57 joomlafailure Benutzername und Passwort falsch oder das Benutzerkonto existiert noch nicht!
2022-10-13T12:29:33+00:00 INFO 194.34.132.57 joomlafailure Benutzername und Passwort falsch oder das Benutzerkonto existiert noch nicht!
2022-10-13T12:36:09+00:00 INFO 194.34.132.57 joomlafailure Username and password do not match or you do not have an account yet.
2022-10-13T12:36:12+00:00 INFO 194.34.132.57 joomlafailure Username and password do not match or you do not have an account yet.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);