using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.*?)(\btrans\(['""]?)([^,'"")]*)((.*?)(\btrans\(['""]?)([^,'"")]*))?((.*?)(\btrans\(['""]?)([^,'"")]*))?((.*?)(\btrans\(['""]?)([^,'"")]*))?((.*?)(\btrans\(['""]?)([^,'"")]*))?((.*?)(\btrans\(['""]?)([^,'"")]*))?)(.*)";
string substitution = @"$2";
string input = @"trans('somestring1');
trans(""SomeString2""); some content trans(""SomeString2a"");more stuff
stuff trans(""SomeString2b"");
trans('more_string',$somevar);
trans(""anotherstring4"",$somevar);
trans($tx_key);
trans($anotherKey,$somevar); extra stuff
qqqqqq trans($anotherKey,$somevar);qqqqqqq
// works for up to 6trans(...)"" entries
trans(""SomeString1""); some content trans(""SomeString2"");more trans(""SomeString3"");stuff trans(""SomeString4""); some content trans(""SomeString5"");more trans(""SomeString6"");";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}