// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((.*?)(\btrans\(['"]?)([^,'")]*)((.*?)(\btrans\(['"]?)([^,'")]*))?((.*?)(\btrans\(['"]?)([^,'")]*))?((.*?)(\btrans\(['"]?)([^,'")]*))?((.*?)(\btrans\(['"]?)([^,'")]*))?((.*?)(\btrans\(['"]?)([^,'")]*))?)(.*)"#).unwrap();
let string = "trans('somestring1');
trans(\"SomeString2\"); some content trans(\"SomeString2a\");more stuff
stuff trans(\"SomeString2b\");
trans('more_string',$somevar);
trans(\"anotherstring4\",$somevar);
trans($tx_key);
trans($anotherKey,$somevar); extra stuff
qqqqqq trans($anotherKey,$somevar);qqqqqqq
// works for up to 6trans(...)\" entries
trans(\"SomeString1\"); some content trans(\"SomeString2\");more trans(\"SomeString3\");stuff trans(\"SomeString4\"); some content trans(\"SomeString5\");more trans(\"SomeString6\");";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}