import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[/?&](?:e|vi?|ci)(?:[/=]|%3D)|youtu\\.be/|embed/|/user/[^/]+#p/(?:[^/]+/)+)\\K[\\w-]{10,12}";
final String string = "https://www.youtube.com/watch?v=-SXKV0jDxuA\n"
+ "https://www.youtube.com/watch?v=ylfhCpi9AEU\n"
+ "http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://youtu.be/-wtIMTCHWuI\n"
+ "http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg\n"
+ "http://youtu.be/zc0s358b3Ys\n"
+ "http://www.youtube.com/embed/zc0s358b3Ys\n"
+ "http://www.youtube.com/watch?v=zc0s358b3Ys\n"
+ "http://www.youtube.com/v/ZTUVgYoeN_b?f=gdata_standard\n"
+ "https://www.youtube.com/embed/WVZpCdHq3Qg\n"
+ "http://www.youtube.com/watch?argv=xyz&v=u8nQa1cJyX8\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o\n"
+ "http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg\n"
+ "http://youtu.be/0zM3nApSvMg\n"
+ "youtube.com/shared?ci=MZZ02_0O6GQ\n"
+ "//www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0\n"
+ "http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo\n"
+ "http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
+ "http://www.youtube.com/user/SilkRoadTheatre#p/a/u/2/6dwqZw0j_jY\n"
+ "http://youtu.be/6dwqZw0j_jY\n"
+ "http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be\n"
+ "http://youtu.be/afa-5HQHiAs\n"
+ "http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo?rel=0\n"
+ "http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
+ "http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
+ "http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
+ "http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
+ "http://www.youtube.com/watch?v=peFZbP64dsU\n"
+ "http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/vi/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "http://youtube.com/?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
+ "http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
+ "https://www.youtube.com/watch?v=UzRtrjyDwx0\n"
+ "https://youtu.be/6butf1tEVKs?t=22s\n"
+ "https://youtu.be/R46-XgqXkzE?t=2m52s\n"
+ "http://youtu.be/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/?v=dQw4w9WgXcQ\n"
+ "http://www.youtube.com/?v=dQw4w9WgXcQ&feature=player_embedded\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=player_embedded\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/e/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/embed/dQw4w9WgXcQ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}