import re
regex = re.compile(r"\w+\@\w+\.\w+", flags=re.MULTILINE)
test_str = ("lastname,firstname,surname,organization,position,phone,email\n"
"Усольцев Олег Валентинович,,,ФНС,главный специалист – эксперт отдела взаимодействия с федеральными органами власти Управления налогообложения имущества и доходов физических лиц,+7 (495) 913-04-78,opendata@nalog.ru\n"
"Мартиняхин Виталий Геннадьевич,,,ФНС,,+74959130037,\n"
"Наркаев,Вячеслав Рифхатович,,ФНС,,8 495-913-0168,\n"
"Мартиняхин,Виталий,Геннадьевич,ФНС,cоветник отдела Интернет проектов Управления информационных технологий,,,\n"
"Лукина Ольга Владимировна,,,Минфин,,+7 (495) 983-36-99 доб. 2926,Olga.Lukina@minfin.ru\n"
"Паньшин Алексей Владимирович,,,Минфин,,8(495)748-49-73,1248@minfin.ru\n"
"Лагунцов Иван Алексеевич,,,Минфин,,+7 (495) 913-11-11 (доб. 0792),\n"
"Лагунцов Иван,,,,,,Ivan.Laguntcov@minfin.ru")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")