import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Text|FooKeyword|AnotherKeyword): ?(.+?)(?=\\n(Text|FooKeyword|AnotherKeyword)|$)";
final String string = "Text: Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco\n"
+ " laboris nisi ut aliquip ex ea commodo consequat.\n\n"
+ "FooKeyword: Foo\n"
+ "AnotherKeyword: Yay!";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}