const regex = /(Text|FooKeyword|AnotherKeyword): ?(.+?)(?=\n(Text|FooKeyword|AnotherKeyword)|$)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Text|FooKeyword|AnotherKeyword): ?(.+?)(?=\\n(Text|FooKeyword|AnotherKeyword)|$)', 'gs')
const str = `Text: Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco
laboris nisi ut aliquip ex ea commodo consequat.
FooKeyword: Foo
AnotherKeyword: Yay!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}