using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*?)(\.[a-zA-Z0-9]+?)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\d+.\d+)(_\d{4,8})?(_D\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)";
string input = @"p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName
p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip
p_SPEC.Delta_v13.0_20181110_D1.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}