import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[putdn])(_[a-zA-Z]+?[a-zA-Z0-9]*?)(\\.[a-zA-Z0-9]+?)?(.Delta|.Snapshot|.Event)(D|W|M|BM|Q|Y)?(_v\\d+.\\d+)(_\\d{4,8})?(_D\\d+)(_[a-zA-Z]+[a-zA-Z0-9]*)";
final String string = "p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip\n"
+ "p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA.zip\n"
+ "p_SPEC.operation.DeltaD_v13.0_20181110_D1_sourceSystemA_A_N10_packageName\n"
+ "p_SPEC.operation.Delta_v13.0_20181110_D1_sourceSystemA.zip\n"
+ "p_SPEC.Delta_v13.0_20181110_D1_sourceSystemA.zip\n"
+ "p_SPEC.Delta_v13.0_20181110_D1.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}