#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+/\d+/\d+ .*(?:\n(?!^\d+/\d+/\d+ ).*)*"
Local $sString = "05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC" & @CRLF & _
"" & @CRLF & _
"COM" & @CRLF & _
"Payable: 05/06/2021" & @CRLF & _
"QUALIFIED DIVIDENDS 23.50 " & @CRLF & _
"" & @CRLF & _
"ATVI - 0.00 23.50 (9,425.77)" & @CRLF & _
"" & @CRLF & _
"05/13/21 05/13/21 Margin Div/Int - Income APPLE INC" & @CRLF & _
"COM" & @CRLF & _
"Payable: 05/13/2021" & @CRLF & _
"QUALIFIED DIVIDENDS 6.16 " & @CRLF & _
"" & @CRLF & _
"AAPL - 0.00 6.16 (9,419.61)" & @CRLF & _
"" & @CRLF & _
"05/28/21 05/28/21 Margin Div/Int - Income STARBUCKS CORP" & @CRLF & _
"COM" & @CRLF & _
"Payable: 05/28/2021" & @CRLF & _
"QUALIFIED DIVIDENDS 18.00 " & @CRLF & _
"" & @CRLF & _
"SBUX - 0.00 18.00 (9,401.61)" & @CRLF & _
"" & @CRLF & _
"05/28/21 05/28/21 Margin Div/Int - Expense MARGIN INTEREST CHARGE" & @CRLF & _
"Payable: 05/28/2021 " & @CRLF & _
"" & @CRLF & _
" - - 0.00 (73.03) (9,474.64)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")