import re
regex = re.compile(r"^\d+/\d+/\d+ .*(?:\n(?!^\d+/\d+/\d+ ).*)*", flags=re.MULTILINE)
test_str = ("05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\n"
"COM\n"
"Payable: 05/06/2021\n"
"QUALIFIED DIVIDENDS 23.50 \n\n"
"ATVI - 0.00 23.50 (9,425.77)\n\n"
"05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\n"
"COM\n"
"Payable: 05/13/2021\n"
"QUALIFIED DIVIDENDS 6.16 \n\n"
"AAPL - 0.00 6.16 (9,419.61)\n\n"
"05/28/21 05/28/21 Margin Div/Int - Income STARBUCKS CORP\n"
"COM\n"
"Payable: 05/28/2021\n"
"QUALIFIED DIVIDENDS 18.00 \n\n"
"SBUX - 0.00 18.00 (9,401.61)\n\n"
"05/28/21 05/28/21 Margin Div/Int - Expense MARGIN INTEREST CHARGE\n"
"Payable: 05/28/2021 \n\n"
" - - 0.00 (73.03) (9,474.64)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")