import Foundation
let pattern = #"[\w\W]+?Code[\w\W]+?(?<po_number>\d{8})\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s\|[\w\W]+?\s|\s\|[\w\W]+?\s\|[\w\W]+?\s\|\s(?<reason>[\w\W]+?)\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
The Acme Corp has requested you cancel the following order(s) as soon as possible.
If you're unable to cancel the order(s), or have questions about the reason for canceling, please contact Acme Corp directly.
For the best support, please do not reply to this email.
PO# | Order Received On | Ship-to Zip Code
12345678 | 2024-03-21 18:26:54 |
Line # | Merchant SKU | Vendor SKU | Cancel Qty | Cancel Reason | Packing Slip Bundle
1 | 1XX718YY40 | 654321 | 1 | Cancelled at Merchant's Request | 19205839
Depending on the business rules, you may need to include some of these details on the fulfillment confirmation you use to cancel the order.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)