use strict;
my $str = '#000#000#000031419 102900107 8*902 17145550104 71234 88888 0 0244 71247 0 0000101 #015
#000#000#000031419 132500329 #060 713312155555331 50042424 25331 0 0000316 #015';
my $regex = qr/^(\S+\s+){3}(?<originating>\S+)\s+(?<exchange>\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}