import Foundation
let pattern = #"^(\S+\s+){3}(?<originating>\S+)\s+(?<exchange>\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#000#000#000031419 102900107 8*902 17145550104 71234 88888 0 0244 71247 0 0000101 #015
#000#000#000031419 132500329 #060 713312155555331 50042424 25331 0 0000316 #015
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)