const regex = /(?=(?<gender_code>\d\d))(?<style>\d{6})(?<width>\d{1}[ABDE])(?<color_code>\d{3})\.(?<size_code>\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?<gender_code>\\d\\d))(?<style>\\d{6})(?<width>\\d{1}[ABDE])(?<color_code>\\d{3})\\.(?<size_code>\\d{3})', 'gm')
const str = `1102961D048.075`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}