re = /(?=(?<gender_code>\d\d))(?<style>\d{6})(?<width>\d{1}[ABDE])(?<color_code>\d{3})\.(?<size_code>\d{3})/m
str = '1102961D048.075'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end