# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(_(\d)+(\.rds)*)//gm;t' <<< "l <- c(\"F1_6346346346_TrainTest_53453465.rds\", \"F1_64575687357_FunctionTest_747434534.rds\", \"F3F4_546345647678_TrainTest_453463654.rds\""