// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(_(\d)+(\.rds)*)").unwrap();
let string = "l <- c(\"F1_6346346346_TrainTest_53453465.rds\", \"F1_64575687357_FunctionTest_747434534.rds\", \"F3F4_546345647678_TrainTest_453463654.rds\"";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}