#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<td data-table-header="The bank [^"]+">([\d|,|.\+]+)<\/td>"
Local $sString = "<div class='index-currency-table'>" & @CRLF & _
" <!--http://1000hz.github.io/bootstrap-validator/#validator-usage-->" & @CRLF & _
" <div class="row"> " & @CRLF & _
" <div class="col-xs-12"> " & @CRLF & _
" <table class="table--exchange table--exchange--responsive"> " & @CRLF & _
" <thead> " & @CRLF & _
" <tr> " & @CRLF & _
" <th scope="col">Currency</th>" & @CRLF & _
" <th scope="col">Nominal</th>" & @CRLF & _
" <th scope="col">The bank buys</th>" & @CRLF & _
" <th scope="col">The bank sells</th>" & @CRLF & _
" <th scope="col">BNB</th>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody> " & @CRLF & _
" <tr> " & @CRLF & _
" <td data-table-header="Currency"> " & @CRLF & _
" <a href="/en/rates-indexes/currency-rates/USD/" target="_self" title="United States Dollar">" & @CRLF & _
" <span class="flag-icon flag-icon-us"></span> USD" & @CRLF & _
" </a>" & @CRLF & _
" </td>" & @CRLF & _
" <td data-table-header="Nominal">1</td> " & @CRLF & _
" <td data-table-header="The bank buys">1.581200</td>" & @CRLF & _
" <td data-table-header="The bank sells">1.646100</td> " & @CRLF & _
" <td data-table-header="BNB">1.614390</td>" & @CRLF & _
" </tr> " & @CRLF & _
" </tbody>" & @CRLF & _
" </table>" & @CRLF & _
" </div>" & @CRLF & _
" <!--col-->" & @CRLF & _
" </div>" & @CRLF & _
" <!--row-->" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")