# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td data-table-header=\"The bank [^\"]+\">([\d|,|.\+]+)<\/td>"
test_str = ("<div class='index-currency-table'>\n"
" <!--http://1000hz.github.io/bootstrap-validator/#validator-usage-->\n"
" <div class=\"row\"> \n"
" <div class=\"col-xs-12\"> \n"
" <table class=\"table--exchange table--exchange--responsive\"> \n"
" <thead> \n"
" <tr> \n"
" <th scope=\"col\">Currency</th>\n"
" <th scope=\"col\">Nominal</th>\n"
" <th scope=\"col\">The bank buys</th>\n"
" <th scope=\"col\">The bank sells</th>\n"
" <th scope=\"col\">BNB</th>\n"
" </tr>\n"
" </thead>\n"
" <tbody> \n"
" <tr> \n"
" <td data-table-header=\"Currency\"> \n"
" <a href=\"/en/rates-indexes/currency-rates/USD/\" target=\"_self\" title=\"United States Dollar\">\n"
" <span class=\"flag-icon flag-icon-us\"></span> USD\n"
" </a>\n"
" </td>\n"
" <td data-table-header=\"Nominal\">1</td> \n"
" <td data-table-header=\"The bank buys\">1.581200</td>\n"
" <td data-table-header=\"The bank sells\">1.646100</td> \n"
" <td data-table-header=\"BNB\">1.614390</td>\n"
" </tr> \n"
" </tbody>\n"
" </table>\n"
" </div>\n"
" <!--col-->\n"
" </div>\n"
" <!--row-->\n"
"</div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.