package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/rest\/v1\/add\/.+$`)
var str = `/rest/v1/add/6asadadad
/rest/v1/add`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}