import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(AB)\\D*(\\d+)\\S*?(\\d\\d)\\b(?=[',]|-[A-Z]|$)(?!-[A-Z]+-[A-Z]+-[A-Z])";
final String string = "A='AB.224-QW-2018'\n"
+ "B='AB.876-5-LS-2018'\n"
+ "C='AB.26-LS-18'\n"
+ "D='AB-123-6-LS-2017'\n"
+ "IA-Mb-22L-AB.224-QW-2018-IA-Mb-22L' F='ZX-ss-12L-AB-123-6-LS-2017-BC-22\n"
+ "A='AB.224-QW-2018'\n"
+ "B='AB.876-5-LS-2018'\n"
+ "C='AB.26-LS-18'\n"
+ "D='AB-123-6-LS-2017'\n"
+ "E='IA-Mb-22L-AB.224-QW-2018-IA-Mb-22L'\n"
+ "F='ZX-ss-12L-AB-123-6-LS-2017-BC-22'\n"
+ "G='AB.224-2018'\n"
+ "H='AB.224/QW/2018'\n"
+ "I='AB/224/2018'\n"
+ "-AB-231-2-33-12-2017,AB-231-1-HD-2017,AB-231-2017\n\n"
+ "AB-231-2-33-RR-TTLT-ZA-2017";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}