import re
regex = re.compile(r"\b(AB)\D*(\d+)\S*?(\d\d)\b(?=[',]|-[A-Z]|$)(?!-[A-Z]+-[A-Z]+-[A-Z])", flags=re.MULTILINE)
test_str = ("A='AB.224-QW-2018'\n"
"B='AB.876-5-LS-2018'\n"
"C='AB.26-LS-18'\n"
"D='AB-123-6-LS-2017'\n"
"IA-Mb-22L-AB.224-QW-2018-IA-Mb-22L' F='ZX-ss-12L-AB-123-6-LS-2017-BC-22\n"
"A='AB.224-QW-2018'\n"
"B='AB.876-5-LS-2018'\n"
"C='AB.26-LS-18'\n"
"D='AB-123-6-LS-2017'\n"
"E='IA-Mb-22L-AB.224-QW-2018-IA-Mb-22L'\n"
"F='ZX-ss-12L-AB-123-6-LS-2017-BC-22'\n"
"G='AB.224-2018'\n"
"H='AB.224/QW/2018'\n"
"I='AB/224/2018'\n"
"-AB-231-2-33-12-2017,AB-231-1-HD-2017,AB-231-2017\n\n"
"AB-231-2-33-RR-TTLT-ZA-2017")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")