using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(.*?)\((.*?)\)";
string substitution = @"$1$2";
string input = @"Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}