$re = '/(\(.*?)\((.*?)\)/m';
$str = 'Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;