import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<address>\\d{1,3}(?:\\.\\d{1,3}){2}\\.(?<FromSeg>\\d{1,3}))(?:(?:\\/|\\s+\\/\\s+)(?<CIDR>\\d{1,2})|(?:-|\\s+to\\s+)(?<ToSeg>\\d{1,3}(?![\\d\\.]))|(?:-|\\s*to\\s+)(?<ToIP>\\d{1,3}(?:\\.\\d{1,3}){3})|\\s+(?<Mask>25\\d(?:\\.\\d{1,3}){3})|\\s*)?";
final String string = "56.1.2.3/24\n"
+ "56.1.2.4-7\n"
+ "56.1.2.4-255.0.0.0\n"
+ "56.1.2.4 to 7\n"
+ "56.1.2.4 to 56.1.2.7\n"
+ "56.1.2.3 / 24 \n"
+ "56.1.2.3\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}