const regex = /(?<address>\d{1,3}(?:\.\d{1,3}){2}\.(?<FromSeg>\d{1,3}))(?:(?:\/|\s+\/\s+)(?<CIDR>\d{1,2})|(?:-|\s+to\s+)(?<ToSeg>\d{1,3}(?![\d\.]))|(?:-|\s*to\s+)(?<ToIP>\d{1,3}(?:\.\d{1,3}){3})|\s+(?<Mask>25\d(?:\.\d{1,3}){3})|\s*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<address>\\d{1,3}(?:\\.\\d{1,3}){2}\\.(?<FromSeg>\\d{1,3}))(?:(?:\\\/|\\s+\\\/\\s+)(?<CIDR>\\d{1,2})|(?:-|\\s+to\\s+)(?<ToSeg>\\d{1,3}(?![\\d\\.]))|(?:-|\\s*to\\s+)(?<ToIP>\\d{1,3}(?:\\.\\d{1,3}){3})|\\s+(?<Mask>25\\d(?:\\.\\d{1,3}){3})|\\s*)?', 'g')
const str = `56.1.2.3/24
56.1.2.4-7
56.1.2.4-255.0.0.0
56.1.2.4 to 7
56.1.2.4 to 56.1.2.7
56.1.2.3 / 24
56.1.2.3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}