using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([A-Z]|\d)+\.?)+(?=\.\w+\.\w+)";
string input = @"A.B.CD.1.EF.2.G.3.HI.JKL";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}