$re = '/(([A-Z]|\d)+\.?)+(?=\.\w+\.\w+)/';
$str = 'A.B.CD.1.EF.2.G.3.HI.JKL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);