const regex = /^https?:\/\/((?:[a-z0-9]-?)+[^-\.]\.)?(?:[a-z0-9]-?)+[^-\.]\.[a-z]{2,15}(?:\.[a-z]{2})?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/((?:[a-z0-9]-?)+[^-\\.]\\.)?(?:[a-z0-9]-?)+[^-\\.]\\.[a-z]{2,15}(?:\\.[a-z]{2})?$', 'gmi')
const str = `######################## Match
http://www.example.co.sa
http://www.some-domain-name.com
http://WWW.EXAMPLE.NET
http://www.google.com
http://www.some-site.engineering
https://www.google.com
http://www.efg-cba.asdfgh
https://some-sub-domain.exam-ple.musem.uk
http://sub-domain.example-site.engineering
http://test-www.mi-creativity.com
https://google.co.in
http://maps.google.com
http://abc.site-name.com
http://google.com
######################## NO Match
www.google
www.google.com
mail.google.com
://www.google
//www.google
:google.com
http://www..google.co.sa
http://www.google..co.uk
http://www.google.co..uk
htt:google.com
http:google.com
http:/google.com
http//www.google.com
http://www.go ogle.com
http://www.google.c om
http://abc.-google.com
http://efg.g--oogle.com
http://xyz.google-.com
http://abc.-google.com
http://efg.g--oogle.com
http://cba.example.c
http://lm.example.co.i
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}