# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?:\/\/((?:[a-z0-9]-?)+[^-\.]\.)?(?:[a-z0-9]-?)+[^-\.]\.[a-z]{2,15}(?:\.[a-z]{2})?$"
test_str = ("######################## Match\n"
"http://www.example.co.sa\n"
"http://www.some-domain-name.com\n"
"http://WWW.EXAMPLE.NET\n"
"http://www.google.com\n"
"http://www.some-site.engineering\n"
"https://www.google.com\n"
"http://www.efg-cba.asdfgh\n"
"https://some-sub-domain.exam-ple.musem.uk\n"
"http://sub-domain.example-site.engineering\n"
"http://test-www.mi-creativity.com\n"
"https://google.co.in\n"
"http://maps.google.com\n"
"http://abc.site-name.com\n"
"http://google.com\n\n"
"######################## NO Match\n"
"www.google\n"
"www.google.com\n"
"mail.google.com\n"
"://www.google\n"
"//www.google\n"
":google.com\n"
"http://www..google.co.sa\n"
"http://www.google..co.uk\n"
"http://www.google.co..uk\n"
"htt:google.com\n"
"http:google.com\n"
"http:/google.com\n"
"http//www.google.com\n"
"http://www.go ogle.com\n"
"http://www.google.c om\n"
"http://abc.-google.com \n"
"http://efg.g--oogle.com \n"
"http://xyz.google-.com\n"
"http://abc.-google.com\n"
"http://efg.g--oogle.com\n"
"http://cba.example.c\n"
"http://lm.example.co.i\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.