$re = '/(?:a+(?=.*X))(?<=^.{0,4})/m';
$str = 'aaaaaaaaX
baaaaaaaaX
bbaaaaaaaaX
bbbaaaaaaaaX
bbbbaaaaaaaaX
babaaaaaaaaX
aX
abaaX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);