re = /(?:a+(?=.*X))(?<=^.{0,4})/m
str = 'aaaaaaaaX
baaaaaaaaX
bbaaaaaaaaX
bbbaaaaaaaaX
bbbbaaaaaaaaX
babaaaaaaaaX
aX
abaaX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end