$re = '/^(.*[^\(]\d{4}[^\)]?)$/m';
$str = 'Example one 2015
Example two 2017
Example three (2009)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);