re = /^(.*[^\(]\d{4}[^\)]?)$/m
str = 'Example one 2015
Example two 2017
Example three (2009)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end