$re = '/^(\w+).*(?:\r?\n(?!\1).+)*(?<!\s)/m';
$str = 'Auth= bigben.com\\\\Dileja
Server = ringring.com
Config = teststringA
Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth = dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth = dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);