re = /^(\w+).*(?:\r?\n(?!\1).+)*(?<!\s)/m
str = 'Auth= bigben.com\\\\Dileja
Server = ringring.com
Config = teststringA
Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth = dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth = dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end