// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\S*\d\S*)|([^\s\d]+)").unwrap();
let string = "Nike Air Max 97
Adidas NMD-R1
Nike Air Max 270";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}