re = /^(?!\s)[a-zA-Z\d$#@ ]{1,5}(?<!\s)$/m
str = 'Hell@
He @@
Hel@
Hell
Hel %
Hell%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end