import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-z]+)_([0-9]+)(_([0-9]+))*)\\-([0-9]+)x([0-9]+)\\-([0-9]{1})([0-9abcdef]{6}){0,1}\\.(jpg|gif|png)";
final String string = "attractions_300-217x168-1.jpg\n"
+ "villa_27_11213-850x567-1.jpg\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}