import Foundation
let pattern = #"^(([a-z]+)_([0-9]+)(_([0-9]+))*)\-([0-9]+)x([0-9]+)\-([0-9]{1})([0-9abcdef]{6}){0,1}\.(jpg|gif|png)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
attractions_300-217x168-1.jpg
villa_27_11213-850x567-1.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}