#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^\n]*?rolf[^\n]*$).*$"
Local $sString = "roooolf" & @CRLF & _
"r123olf" & @CRLF & _
"123rolf123" & @CRLF & _
"rolf5623" & @CRLF & _
"123rolf" & @CRLF & _
"rollllf" & @CRLF & _
"rrrrrrolf" & @CRLF & _
"rolffff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")